Jump to content


Photo
* * * * * 13 votes

Modification to repair FTE issues on Saigas with blocked gas ports


  • Please log in to reply
274 replies to this topic

#61 Jangles

Jangles

    Member

  • Contributor
  • Pip
  • 80 posts
  • Gender:Male
  • Location:Arizona

Posted 15 February 2009 - 07:57 PM

My S12 is scheduled for delivery tomorrow back from CGW! I'll let ya'll know how it works.

Edited by Jangles, 15 February 2009 - 07:58 PM.

Do you raelly think they can't take your guns away?
Click it and read.
http://www.armytimes...meland_090708w/


Posted Image

#62 MWebb

MWebb

    Newbie

  • Member
  • 2 posts

Posted 22 February 2009 - 04:04 AM

Remove the gas regulator and take a CLOSE look at your gas ports with a good flashlight. Use a paperclip to clean out the ports you can see. If you can only see one port clearly, then this mod will make a big difference in the way your gun functions.


Glad I found your posts on FTE. My new Saiga 12 does nothing but FTE on both settings with standard target shells (NOT light load), so I tried moving up to higher brass... 1290 fps, 1300, fps, 1330 fps, etc. Nothing would eject. I checked the gas port against your pictures and descriptions and it looks like I have a poorly machined/aligned Saiga. I couldn't see any holes in the barrel after removing the plug, but I found (by feel) 2 tiny holes I can get through using a hooked piece of paper clip. Then I could see the wire in the barrel. The holes are practically under the threaded area instead of visible from the the hole in the gas tube, and just big enough for the paper clip wire to get through.

Has anyone run into a Saiga 12 this far off, and do you think I should go through RAA or try this mod?

#63 Bounce12

Bounce12

    Your mortgage and your health care are NOT our problem!

  • Contributor
  • PipPipPipPipPip
  • 2,882 posts
  • Gender:Male

Posted 22 February 2009 - 09:44 AM

Has anyone run into a Saiga 12 this far off, and do you think I should go through RAA or try this mod?



I did both.

I had a blocked two-holer. I sent it back in and they gave me a three-holer in exchange. It wasn't enough. So, I did the mod.



I have no particular hand-skills with tools, either. The mod is not that difficult, but I'd try a factory replacement first.
This post is being monitored by agencies of the US Federal Government

#64 Jangles

Jangles

    Member

  • Contributor
  • Pip
  • 80 posts
  • Gender:Male
  • Location:Arizona

Posted 22 February 2009 - 05:13 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles
  • superwrench0166 likes this
Do you raelly think they can't take your guns away?
Click it and read.
http://www.armytimes...meland_090708w/


Posted Image

#65 Hammer

Hammer

    Member

  • Contributor
  • Pip
  • 94 posts
  • Gender:Male
  • Location:Finland

Posted 24 February 2009 - 04:02 PM

I have 12C with barrel cut 43cm. There was originally 3 gas ports and gun works with 28g high velocity trap ammos but didn't eject 28g slugs or other light loads like 24g skeet. Today I made one gas port more. I think that now it cycles with all loads.

#66 tommygunner

tommygunner

    Member

  • Member
  • Pip
  • 45 posts

Posted 27 February 2009 - 06:32 PM

Just thought I would add a bit to this post. Last week I got my new S-12, Took it out and shot it. Cycled high brass and buckshot good but would not eject low base 3 1/4 or less dram loads worth a damn.
Got home and checked things out and found I had a 2 hole gun with one of the gas ports partially covered by the gas block. I decided to fix it myself instead of warranty it.
I did the fix on the gas block as outlined in the start of this thread. plus cleaned out the gas ports good with a drill bit of the same size. I did not enlarge them or add any holes! Then I polished up the bolt, hammer, ect as outlined in the other sticky thread(s)
Put my gun back together. It was smoother but it still seemed real stiff and rough when the bolt was pulled back all the way.
Pulled off the receiver cover, and cycled the bolt to see why it was soo rough to pull the last inch or so.
Noticed that the return spring was hanging up on the rear of the bolt support. Where it slides over the return spring.
Took the bolt support and spring out and had a good look at it. The hole in the bolt support that the spring is guided into was very rough with bumps ridges and other rough casting marks.
I got out a round and flat file and cleaned up the end of the bolt support, smoothed it out approx 1" back in the tube and flared it better so the spring is guided into it smoothly.
WOW! when I put it back together and pulled the bolt back it was very smooth thru the whole cycle.
Took it out and shot it and fell in love with this gun. I dont think I have ever shot a shotgun that cycles this fast. Almost like a full auto...Its so much fun to shoot.
Worked perfect on any loads i put thru it. Even light trap loads that I reload cycled/ ejected perfectly. I shot about 75 rounds of various lighter loads with no FTEs on #2.
I switched to #1 and put some 2 3/4 buck and some 3" steel shot down range. No problems. Then I tried some low base on #1 It cycled everything but low power trap loads. I think That is about where I want it.
Checked the bolt stop to see if it was wearing but it showed no wear except some paint wore off.
I think I am really going to like this gun.
Thanks to JeffD and everyone else who contributes tech to help us newbs out.

Edited by tommygunner, 27 February 2009 - 06:39 PM.

" Built not Bought"

#67 naste

naste

    Newbie

  • Member
  • 1 posts

Posted 01 March 2009 - 06:09 AM

"Took the bolt support and spring out and had a good look at it. The hole in the bolt support that the spring is guided into was very rough with bumps ridges and other rough casting marks.
I got out a round and flat file and cleaned up the end of the bolt support, smoothed it out approx 1" back in the tube and flared it better so the spring is guided into it smoothly."


Is there anyway you can take a picture of where you filed/cleaned up or a littler bit more on how you did it, this is exactly what mine seems to be doing. I have a 3 day old 12 that i have done the gas port mod to and also polished the parts that need polishing but i still FTE. Seems more like the same problem you were having... Pics or a better description would be awesome, Thanks.

#68 Jackashe

Jackashe

    Newbie

  • Member
  • 6 posts

Posted 01 March 2009 - 03:35 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles

:unsure: Jangles, how did you go about getting the warranty work completed. What are the steps, who do you contact, etc...
Thanks!!!

#69 Jackashe

Jackashe

    Newbie

  • Member
  • 6 posts

Posted 01 March 2009 - 03:36 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles

:unsure: Jangles, how did you go about getting the warranty work completed. What are the steps, who do you contact, etc...
Thanks!!!



#70 Jackashe

Jackashe

    Newbie

  • Member
  • 6 posts

Posted 01 March 2009 - 03:42 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles

Sorry,
Hit the wrong button. I have a two hole port. One is partially covered. Should I send it back to RACC to get a 3 hole? If so, what are the procedures to do that? Will they send a new gun? Will I have to still get the modification you just did if they send a 3 hole?
Thanks for your help! I am very frustrated with my saiga now. It has an FTE on every round in both 1 and 2 positions. Just looking to get it fix with as less pain as possible.

#71 Jangles

Jangles

    Member

  • Contributor
  • Pip
  • 80 posts
  • Gender:Male
  • Location:Arizona

Posted 01 March 2009 - 07:51 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles

Sorry,
Hit the wrong button. I have a two hole port. One is partially covered. Should I send it back to RACC to get a 3 hole? If so, what are the procedures to do that? Will they send a new gun? Will I have to still get the modification you just did if they send a 3 hole?
Thanks for your help! I am very frustrated with my saiga now. It has an FTE on every round in both 1 and 2 positions. Just looking to get it fix with as less pain as possible.



It's really simple. Give CGW a call and they will email you a paid sticker for UPS. They will pick it up and it will come back to you paid. Will cost you nada and you get to keep your warranty. These other fixes are probably fine but it will void the warranty. CGW # 740-942-3175
Do you raelly think they can't take your guns away?
Click it and read.
http://www.armytimes...meland_090708w/


Posted Image

#72 Jackashe

Jackashe

    Newbie

  • Member
  • 6 posts

Posted 01 March 2009 - 08:55 PM

Okay folks here's the deal with Cadiz Gun Works and Warranty work. I got my gun back in a very timely manner(3 weeks total) and it works great! It feeds great and ejects wonderful. It even cycles my wimpy Skeet reloads. That's a big plus for my money. One other thing, the work, and shipping didn't cost me one dime, it was all taken care of! That's customer service. Plus I didn't have to go anywhere to ship it. CGW emailed me a pickup tag and UPS fetched it. If you can wait just a little while to have it fixed and fixed right I suggest you take advantage of the Warranty provided by RACC and send it to CGW. Plus, I still have warranty left for using this FREE service!!! No, I am NOT related nor do I know anyone at CGW I am just a very pleased customer.
Jangles

Sorry,
Hit the wrong button. I have a two hole port. One is partially covered. Should I send it back to RACC to get a 3 hole? If so, what are the procedures to do that? Will they send a new gun? Will I have to still get the modification you just did if they send a 3 hole?
Thanks for your help! I am very frustrated with my saiga now. It has an FTE on every round in both 1 and 2 positions. Just looking to get it fix with as less pain as possible.



It's really simple. Give CGW a call and they will email you a paid sticker for UPS. They will pick it up and it will come back to you paid. Will cost you nada and you get to keep your warranty. These other fixes are probably fine but it will void the warranty. CGW # 740-942-3175

Thanks for the help!!!!!

#73 destroytec

destroytec

    Member

  • Contributor
  • Pip
  • 84 posts
  • Gender:Male

Posted 02 March 2009 - 10:09 AM

I need help. I cannot seem to get the lower pin out to remove the block. Any advise would be great.

#74 tommygunner

tommygunner

    Member

  • Member
  • Pip
  • 45 posts

Posted 02 March 2009 - 11:16 AM

Is there anyway you can take a picture of where you filed/cleaned up or a littler bit more on how you did it, this is exactly what mine seems to be doing. I have a 3 day old 12 that i have done the gas port mod to and also polished the parts that need polishing but i still FTE. Seems more like the same problem you were having... Pics or a better description would be awesome, Thanks.


Here are some pics of the bolt support where I cleaned it up. If you compare them to your un worked bolt support you can see where i cleaned up and flared the throat where the spring is guided in. I did not remove much metal just enough to remove the rough areas and any ridges/ bumps, casting flash.

Attached File  45acp_015.jpg   709.02KB   30 downloads

Attached File  45acp_016.jpg   780.93KB   27 downloads

On my gun the spring was binding and catching on the edge and first 1/2 inch or so in the throat. Cleaning up that area made my bolt operate nice and smooth. Where before the bolt return would catch on the spring and stop before the end of its stroke. Now it slides smoothly over the spring and the spring is guided straight into the hole in the bolt support.
You want a little Resistance to the bolt at the very end of the stroke. It helps cushion the bolt before it hits the bolt stop.
But my gun was stooping the bolt right at the same place where the shell should eject.
My S12 works great now.
I have put about 75 rounds thru my 2 hole gun without any FTE on light loads on gas setting #2. Heavy loads work perfect on #1. It cycles nice and fast.
If you do this mod. Be sure to clean up everything good and oil the return spring with a quality gun oil. Not wd40.
Hope this helps.

Edited by tommygunner, 02 March 2009 - 11:17 AM.

" Built not Bought"

#75 charveljackson

charveljackson

    Newbie

  • Member
  • 2 posts

Posted 07 March 2009 - 02:18 PM

Thank you very much for you input. I just bought a saiga 12 and it has this exact problem.
I will perform this upgrade tonight and test at the range tomorrow.
Dan
Better to be judged by 12 than carried by 6
dead crimminals can't sue and ther's only one side of the story.

#76 GimmeLiberty

GimmeLiberty

    Member

  • Member
  • Pip
  • 89 posts

Posted 10 March 2009 - 11:22 PM

I would suggest people send in the gun for warranty repair OR get the King Armory gas piston and see if it helps. I had a 3 holer that would only cycle high brass. The cheap low brass would not cycle at all, or dribble out of the ejection port if it happened to cycle. I put in the KA gas piston and my S12 now throws the low brass out of the gun. It made a huge difference for my shotgun and wasn't an expensive fix.
No free man shall ever be debarred the use of arms.
-Thomas Jefferson

#77 JesseJames

JesseJames

    Member

  • Member
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Lancaster, PA

Posted 11 March 2009 - 11:11 PM

Here's my experience with all of this vodka drunk madness!

My S-12 came with two ports and they were both partially blocked by the gas block. It would cycle 2 3/4" magnum loads on 1 with no problem. It would cycle federal value packs about 50% on 2. It wouldn't cycle any of my light target loads.

Step 1. I did the fix mentioned here and filed away at my gas block until both ports were fully exposed. I took the gun out to the range and tried my luck again. Setting one setting two, it didn't matter, 2 ports just weren't pushing enough gas to make the value packs or anything lighter work.

Step 2. I polished the hammer face, the bottom of the bolt carrier where the hammer drags as it's being re-cocked, and the bolt where I was told to do so in another post. After that I had the federal value packs cycling around 80% and the light target loads still were running at 0%

Step 3. I finally sent the gun into Cadiz Gun Works because step 1, step 2, and the fact that I already did the P=Grip conversion voided my ability to return the gun for replacement. I got the gun back in around 3-4 weeks with another port added. I now have a 3 porter that will cycle the lightest of my loads 100% so far even on setting 1.

The moral of the story: if you have a vodka special either contact RRA and return it for a propperly gassed/alligned rifle or just send it to CGW and they'll make it all better!

#78 chrisjenn97

chrisjenn97

    Newbie

  • Member
  • 2 posts

Posted 15 March 2009 - 08:45 PM

Great directions! It definitely took a spare set of hands and some patience. The most difficult part was getting the lower pin removed. I'm anxious to test it this week. Thanks. Chris

#79 Viva la Zombist

Viva la Zombist

    Newbie

  • Member
  • 2 posts

Posted 16 March 2009 - 10:43 PM

Can't get the bottom pin out of the gas block. Almost looks partially welded on the one side. Any hints?

#80 king a

king a

    Advanced Member

  • Contributor
  • PipPip
  • 397 posts
  • Gender:Male
  • Location:Arizona

Posted 16 March 2009 - 10:47 PM

Can't get the bottom pin out of the gas block. Almost looks partially welded on the one side. Any hints?


Drive it out from the other side, sometimes Ivan mashes the pins pretty bad when installing them. The pins are made from a fairly soft steel and it deforms easily.

#81 Viva la Zombist

Viva la Zombist

    Newbie

  • Member
  • 2 posts

Posted 17 March 2009 - 07:17 AM

Thanks.

#82 C2Shooter

C2Shooter

    Member

  • Member
  • Pip
  • 11 posts

Posted 20 March 2009 - 05:18 PM

I decided to tackle this "Vodka Special" myself. I followed the excellent instructions and got everything together and lined up the first try. Only two gas port holes on my S-12 but at least now they're visible through the opening in the gas block. I'll take her to the range tomorrow and see if it solved the FTE issue. It might need another hole in the gas port, but that will be a job for Cadiz Gun Works. Thanks JeffD for the info!

Edited by C2Shooter, 20 March 2009 - 05:28 PM.


#83 Psssniper

Psssniper

    Member

  • Contributor
  • Pip
  • 34 posts

Posted 23 March 2009 - 01:19 AM

Checked my S-12 out with a paperclip and flashlight, found two holes near the very front of the gashole(?) I assumed that one or two more might be buried so I followed your tutorial. It all came apart easily and it all went back together just as easy, guess I got lucky. Big suprise though! these were the only two holes in the barrel. I found the drill number size of the existing holes and then enlarged them. (45 to a 44 if I remember correctly) then since there was tons of room I added another hole and yes I angled it forward just like the factory holes. I decided to drill because I have already modded and polished the bolt & hammer, put in a KA piston and the gun still had FTE's on the value paks. I'll report back after the next test run.

As you can see in the pic it cycles 00 buck just fine (before mods)
Attached File  IMG_3097.JPG   1.03MB   41 downloads

#84 Rustyk

Rustyk

    Newbie

  • Member
  • 4 posts

Posted 24 March 2009 - 05:00 PM

Bought my Saiga-12 last weekend. The FTE I have experienced is the last round, which gets caught up in the bolt as it goes back into battery. I presume that my problem is related to the ones posted above?
The rounds we were using were just Federal 7/8 "on sale" loads.

A related question, should the bolt remain open after the last round?

Thanks in advance

Rusty
We Band of Brothers

#85 Pector55

Pector55

    Member

  • Member
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Dover, PA

Posted 24 March 2009 - 07:37 PM

Thank you to the author who took the time to put this write up together. I didn't use the shelf tool but I like the creativity.
My two gasholes were covered but now I can see them and hit them with a paper clip to verify they are open. I used a drill bit which I could already get into the gas ports to just barely open them up a bit more too. I'm anxious to try her out now.
"The constitutions of most of our States assert that all power is inherent in the people; that... it is their right and duty to be at all times armed;..." Thomas Jefferson letter to Justice John Cartwright, June 5, 1824. 1824. ME 16:45.

#86 emptythemag

emptythemag

    Member

  • Member
  • Pip
  • 91 posts
  • Gender:Male
  • Location:South Eastern Pennsylvania

Posted 25 March 2009 - 12:08 AM

Really helpful info...thanks for putting it up.

#87 Psssniper

Psssniper

    Member

  • Contributor
  • Pip
  • 34 posts

Posted 27 March 2009 - 08:15 PM

Went to Iron Sights range today and ran some of the value pak through the S-12 with the two enlarged ports and the newly drilled third port. Was having 100% FTE's until I remembered to change the gas setting,(dohhh!!) then things went to about 10-15% FTE. The FTE's were so close to ejecting, often halfway out of the gun so I am getting close. I have two of the Gunfixer gas plugs on the way from MDARMS I'll give that a try and then if I need to, I'll open up the gasports to a #43 drill.

#88 bsmurph

bsmurph

    Newbie

  • Member
  • 2 posts

Posted 05 April 2009 - 08:33 AM

Solved the FTE issue on my Saiga 12. Thanks for the Info.... My 2 cents to add to the post!!!!!!!!!!!!!!

I used a small framing square to remove the gas block worked like a champ :rolleyes: Then on reassembly I found that a ¾ PVC SCH 40 pipe cut to length to clear the barrel also makes a great tool for installing the gas block.

Hope my first post helps others that do this mod. :killer:
  • Demento likes this

#89 metalxworks

metalxworks

    Newbie

  • Member
  • 2 posts

Posted 10 April 2009 - 01:45 PM

Ok.

New poster here. I am an FFL holder with a small gunshop in ohio. i recently purchased a S-12 to play with and proceded to add the tromix DIY trigger gaurd, pistol grip and other accesories. imagine my amazement when i found the firearm was ejecting unreliably. i found this and other threads on this site and here is my situation.

i checked the gas block and there were two holes, one slightly obstructed. i pushed the gas block forward and drilled a third hole just below the other two. i drilled the two existing slightly oversized, (#44 Drill). Put it all back together. Polished all surfaces. Gas piston settings are correct.

Before: failure to extract and eject low power (2 3/4 D eq) target loads. failure to completely eject (stovepipe) 1-2 rounds per mag, any load.

after: low power loads extract and eject most of the time, still not reliable. regardless, hi power loads (remington and brenneke slugs) still do not eject reliably and i do not think this is a gas problem. i plan to run some tests to verify this, but it seems the bolt carrier is coming all the way back.

when i inspected the ejection of shells as best i could using fired hulls and manual operation, i'm saw what might be a clearence problem as the empties eject. they seem to hang up on either the receiver, or the bolt carrier, or both.

i am thinking of milling the ejection relief on the receiver, a bit deeper and further back. anyone think this might be a good or a bad idea?

i'll let you know what i find out about the gas.

BTW FYI, I mic'ed the bore of my gun and it comes out to be tight, .719 as far as the mic would reach. remington foster slugs shot great out of this barrel. 2.5 " all touching, 5 shot group at 50 yds. one right after another, time enough to aim. i was pleased.

#90 metalxworks

metalxworks

    Newbie

  • Member
  • 2 posts

Posted 10 April 2009 - 01:49 PM

Ok.

New poster here. I am an FFL holder with a small gunshop in ohio. i recently purchased a S-12 to play with and proceded to add the tromix DIY trigger gaurd, pistol grip and other accesories. imagine my amazement when i found the firearm was ejecting unreliably. i found this and other threads on this site and here is my situation.

i checked the gas block and there were two holes, one slightly obstructed. i pushed the gas block forward and drilled a third hole just below the other two. i drilled the two existing slightly oversized, (#44 Drill). Put it all back together. Polished all surfaces. Gas piston settings are correct.

Before: failure to extract and eject low power (2 3/4 D eq) target loads. failure to completely eject (stovepipe) 1-2 rounds per mag, any load.

after: low power loads extract and eject most of the time, still not reliable. regardless, hi power loads (remington and brenneke slugs) still do not eject reliably and i do not think this is a gas problem. i plan to run some tests to verify this, but it seems the bolt carrier is coming all the way back.

when i inspected the ejection of shells as best i could using fired hulls and manual operation, i'm saw what might be a clearence problem as the empties eject. they seem to hang up on either the receiver, or the bolt carrier, or both.

i am thinking of milling the ejection relief on the receiver, a bit deeper and further back. anyone think this might be a good or a bad idea?

i'll let you know what i find out about the gas.

BTW FYI, I mic'ed the bore of my gun and it comes out to be tight, .719 as far as the mic would reach. remington foster slugs shot great out of this barrel. 2.5 " all touching, 5 shot group at 50 yds. one right after another, time enough to aim. i was pleased.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users