Jump to content
Sign in to follow this  
thopkins

need help around oakland, oregon

Recommended Posts

im having trouble getting my s-12 to cycle low brass. i bought the tac plug and still nothing. talking to the ppl in the chat i need the ports bigger. i don't know much about these guns, so would like some help thanks. if anyone in the area can help, please post some ideas

Share this post


Link to post
Share on other sites

have you checked the polishing the bolt thred? also how many rounds have you shot? most of everything you want to know is right here

Share this post


Link to post
Share on other sites

ive shot about 500+ heavy loads, what whould i need to polish the bolt? i don't have a drimmel, is there other ways to polish?, what would it cost to get everyhting polished? thanks for your time guys

Share this post


Link to post
Share on other sites

I polished the underside of mine with a orbital sander and hand sanding with 400 and 600 grit sandpaper on the rails. a dremel helps with profileing the rough edges on the bolt. I live in glide if you want to go shooting some day.

Share this post


Link to post
Share on other sites

hey right on, i guess ill try to get a dremel. it also looks like 2 of the 3 holes are slightly covered but i still can poke with paperclip. be awesome to go shooting if i can get this thing to work right

thanks for the info

Edited by thopkins

Share this post


Link to post
Share on other sites

good to know, i got the carrier and bolt polished and rails smoothed out, not sure if its gonna cycle the light stuff or not. waiting for a nice day to try it out, would be sweet to get together lay some rounds out and bs.

Share this post


Link to post
Share on other sites

I am going to go test mine out tomorow weather permiting. it has been raining like a cow pissing on a flat rock here.

Share this post


Link to post
Share on other sites

Before I even shot my Saiga-12 I took it straight to the gunsmith and had the gas ports and gas block enlarged, bolt and trigger polished, replaced the gas piston with a performance Puc and then added the TAC-47 auto plug. I've had 0 fail to ejects. With 2 out of 3 ports obstructed that could be the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Tromix - Lead Delivery Systems
Dinzag Arms
CHAOS, Inc
Mississippi Auto Arms, Inc
Cobra's Custom
Carolina Shooters Supply
R & R Targets
LONE STAR ARMS
SGM Tactical
Mach 1 Arsenal
K-VAR
C&S Metall-Werkes
American Specialty Ammo
Csspecs Magazines
Phoenix Technology
Evlutionz LLC


  • Chatbox

    Load More
    You don't have permission to chat.
×