Jump to content
Sign in to follow this  
Potus2000

newbie trigger question

Recommended Posts

Help! I finally got a chance to get my 7.62 conversion out to the range and found that when I pull the trigger the first round will fire but not a second. to remedy this I need to move the trigger forward and then the next round will fire. I'm sure I mst have missed something but everything seemed to dry fire OK. Hoping somebody can help me get this. The trigger is a Tapco G2 that was modified by Tromex. For the record, I'm sure the issue is my install and not Tapco or Tromex so please hold off on the hate mail LOL.

 

Thanks for your help and ideas everyone.

Share this post


Link to post
Share on other sites

Hammer spring legs are not properly postioned on the trigger arms, or the hammer spring is installed backward.

Sometimes the spring legs need a little bending to get them to stay in position. Carolina Shooters Supply trigger installation video addresses this issue.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jetmatch. I'm using the JT spring. Do you recommend going back to the original spring?

Without a doubt .....yes. watch this video, pay attention at the six minute mark.

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Tromix - Lead Delivery Systems
Dinzag Arms
CHAOS, Inc
Mississippi Auto Arms, Inc
Cobra's Custom
Carolina Shooters Supply
R & R Targets
LONE STAR ARMS
SGM Tactical
Mach 1 Arsenal
K-VAR
C&S Metall-Werkes
American Specialty Ammo
Csspecs Magazines
Phoenix Technology
Evlutionz LLC


  • Chatbox

    Load More
    You don't have permission to chat.
×