Jump to content
Sign in to follow this  
Daddyoh3

LRBHO does not function on one of my factory mags

Recommended Posts

Just like the title says, 1 works, the other does not. Looking at the mags I can not see a difference. The mag that does not hold the bolt open sometimes jams on round 3 or 4. The other mag runs flawless...on high power slug.  I just recently found that if I hold the mag higher in the well and cycle the bolt manually it holds open....then rack the bolt a couple times and it falls closed....so the mag isn't sitting high enough in the well....what do I check next...I can't exactly change the location of the mag lock hole in the mag, anything I can adjust?

 

Dave

Share this post


Link to post
Share on other sites

Is the hole/tab on the faulty magazine 'regular'. I had a similar issue as you (and the mag would occasionally just drop out!) and on looking more closely the tab at the top of the mag latch hole was poorly formed. I just pried the top tab out a bit with a screw driver and it seems to have fixed the issue.

 

Regular top, problem bottom;

 

75A12F64-088C-4231-B58D-1BA71CC617F7_zps

Share this post


Link to post
Share on other sites

You can widen the feed lips on the mag to allow the shells to sit higher- WARNING- it doesn't take much, bend them outward ever so slightly.

 

As for the LRBHO, there are some mags that the slot in the back is slightly off center, using a file remove a little material off the side that is keeping the tab from popping out.

You should be able to check if that is the problem by cycling the follower up and down slowly by hand to see if the tab always pops out, or which side it's sticking on.

Share this post


Link to post
Share on other sites

Thanx guys, problem solved ! I really thought it was going to be the mag lock/release slot lips, so I tried bending them out a little first. Could not get mag out at all. Avoiding taking it apart I used a butter knife for a little extra release. Got the mag out, put the slot back to normal, good to go, except for not holding the bolt open. So I tried the feed lips, and like  toothandnail said..."it doesn't take much"...first try was too much and made it so it was Very difficult to even open the action...but it stayed open!  So I put it back in just a touch and all worked perfectly. And in doing this adjustment I can easily see why it might jam. thanx for the help.

 

Dave

  • Like 1

Share this post


Link to post
Share on other sites

uhm...made it to the range again this weekend. Still jambing on 3 or 4...5 rnd mag. Seems to be catching the top lip of the barrel with the top front of the shell... 3 inchers don't seem to have a problem, all though the 3 inch was 1760fps. Can the top of the barrel lip be profiled a bit for smoother slide into the barrel...or is that a recipe for disaster?  Maybe the feed lips on the mags just need pinched in "a bit"?  Just trying to get this gun to work....maybe a pump would have been a better choice.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

Tromix - Lead Delivery Systems
Dinzag Arms
CHAOS, Inc
Mississippi Auto Arms, Inc
Cobra's Custom
Carolina Shooters Supply
R & R Targets
LONE STAR ARMS
SGM Tactical
Mach 1 Arsenal
K-VAR
C&S Metall-Werkes
American Specialty Ammo
Csspecs Magazines
Phoenix Technology
Evlutionz LLC


  • Chatbox

    Load More
    You don't have permission to chat.
×
×
  • Create New...